CVE-2024-38473 Apache HTTP Server proxy encoding problem
Attackers can bypass backend authentication by sending improperly encoded URLs through the Apache HTTP Server proxy module.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-38473?
CVE-2024-38473 is a high-severity authentication bypass vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Weakness: CWE-116
Which versions are affected by CVE-2024-38473?
1 open source package ship an affected version, including apache. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.60 |
Products include Apache Http Server, Netapp Ontap.
How do I fix CVE-2024-38473?
Upgrade apache to 2.4.60 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2024-38473 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38473 exists.
Public exploit code: 1 Nuclei template and 2 proofs of concept on GitHub.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2024-38473, AZL-43065, AZL-43133, BELL-CVE-2024-38473, BIT-apache-2024-38473, CLEANSTART-2026-OB27244 and 4 more.