{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38473 exists.","fix":"Upgrade apache to 2.4.60 or later.","what":"CVE-2024-38473 is a high-severity authentication bypass vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38473 and fix it if it is affected.\n\nWhat it is: CVE-2024-38473 is a high-severity authentication bypass vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38473 exists.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38473/ (Markdown: https://insights.sbomify.com/CVE-2024-38473/index.md)","id":"CVE-2024-38473","markdown":"https://insights.sbomify.com/CVE-2024-38473/index.md","name":"CVE-2024-38473","record":{"aliases":["ALPINE-CVE-2024-38473","AZL-43065","AZL-43133","BELL-CVE-2024-38473","BIT-apache-2024-38473","CLEANSTART-2026-OB27244","DEBIAN-CVE-2024-38473","GHSA-hrh5-4ffc-228q","OESA-2024-2051","UBUNTU-CVE-2024-38473"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"low_privilege","summary":"Attackers can bypass backend authentication by sending improperly encoded URLs through the Apache HTTP Server proxy module.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"ontap","vendor":"netapp"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests.\nUsers are recommended to upgrade to version 2.4.60, which fixes this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2024-08-02","github_poc":2,"max_poc_stars":30,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-08-23T14:39:31Z","kind":"github_poc","ref":"https://github.com/juanschallibaum/CVE-2024-38473-Nuclei-Template","stars":30,"title":"Nuclei template to detect Apache servers vulnerable to CVE-2024-38473"},{"date":"2024-08-02T19:57:52Z","kind":"github_poc","ref":"https://github.com/Abdurahmon3236/CVE-2024-38473","stars":3,"title":null},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-38473.yaml","stars":null,"title":"Apache HTTP Server - ACL Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache HTTP Server proxy encoding problem","id":"CVE-2024-38473","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"auth_bypass","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"Apache HTTP Server weakness with encoded question marks in backreferences","id":"CVE-2024-38474"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.60"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2024-38473"}],"prev":{"headline":"Apache HTTP Server on WIndows UNC SSRF","id":"CVE-2024-38472"},"products":["Apache HTTP Server"],"published":"2024-07-01","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass backend authentication by sending improperly encoded URLs through the Apache HTTP Server proxy module.","url":"https://insights.sbomify.com/CVE-2024-38473/"}