# CVE-2024-38473: Apache HTTP Server proxy encoding problem

> Attackers can bypass backend authentication by sending improperly encoded URLs through the Apache HTTP Server proxy module.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2024-38473, AZL-43065, AZL-43133, BELL-CVE-2024-38473, BIT-apache-2024-38473, CLEANSTART-2026-OB27244, DEBIAN-CVE-2024-38473, GHSA-hrh5-4ffc-228q, OESA-2024-2051, UBUNTU-CVE-2024-38473

## What is CVE-2024-38473?

CVE-2024-38473 is a high-severity authentication bypass vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-38473?

1 open source package ship an affected version, including apache. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.60 |

Products: Apache Http Server, Netapp Ontap.

## How do I fix CVE-2024-38473?

Upgrade apache to 2.4.60 or later.

## Is CVE-2024-38473 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38473 exists.

Public exploit code:

- Nuclei template to detect Apache servers vulnerable to CVE-2024-38473 (github_poc): https://github.com/juanschallibaum/CVE-2024-38473-Nuclei-Template
- https://github.com/Abdurahmon3236/CVE-2024-38473 (github_poc): https://github.com/Abdurahmon3236/CVE-2024-38473
- Apache HTTP Server - ACL Bypass (nuclei): http/cves/2024/CVE-2024-38473.yaml

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38473 and fix it if it is affected.

What it is: CVE-2024-38473 is a high-severity authentication bypass vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38473 exists.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38473/ (Markdown: https://insights.sbomify.com/CVE-2024-38473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38473
- OSV: https://osv.dev/vulnerability/CVE-2024-38473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38473/
Summaries are generated and may contain mistakes; the official description above is the record.
