{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-38474 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.60 or later.","what":"CVE-2024-38474 is a high-severity path traversal vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38474 and fix it if it is affected.\n\nWhat it is: CVE-2024-38474 is a high-severity path traversal vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-38474 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38474/ (Markdown: https://insights.sbomify.com/CVE-2024-38474/index.md)","id":"CVE-2024-38474","markdown":"https://insights.sbomify.com/CVE-2024-38474/index.md","name":"CVE-2024-38474","record":{"aliases":["ALPINE-CVE-2024-38474","BELL-CVE-2024-38474","BIT-apache-2024-38474","CLEANSTART-2026-RW47407","DEBIAN-CVE-2024-38474","GHSA-x6g9-g4wf-qrf7","UBUNTU-CVE-2024-38474","USN-6885-4","USN-6885-6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"low_privilege","summary":"Attackers can execute scripts in restricted directories or disclose source code via encoded question marks in mod_rewrite rules.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"clustered_data_ontap","vendor":"netapp"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in\ndirectories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI.\n\nUsers are recommended to upgrade to version 2.4.60, which fixes this issue.\n\nSome RewriteRules that capture and substitute unsafely will now fail unless rewrite flag \"UnsafeAllow3F\" is specified.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server weakness with encoded question marks in backreferences","id":"CVE-2024-38474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server","netapp:clustered_data_ontap"],"type":"path_traversal","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.60"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2024-38474"}],"prev":{"headline":"Apache HTTP Server proxy encoding problem","id":"CVE-2024-38473"},"products":["Apache HTTP Server"],"published":"2024-07-01","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute scripts in restricted directories or disclose source code via encoded question marks in mod_rewrite rules.","url":"https://insights.sbomify.com/CVE-2024-38474/"}