# CVE-2024-38475: Apache HTTP Server Improper Escaping of Output

> Attackers can exploit improper escaping in mod_rewrite to access restricted filesystem paths, leading to code execution or source code disclosure.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Yes, since 1 May 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2024-38475, BELL-CVE-2024-38475, BIT-apache-2024-38475, CLEANSTART-2026-JH66547, DEBIAN-CVE-2024-38475, GHSA-pf44-j75v-mhr8, UBUNTU-CVE-2024-38475

## What is CVE-2024-38475?

CVE-2024-38475 is a critical path traversal vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper escaping of output in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to map URLs to filesystem locations that are permitted to be served by the server but are not intentionally/directly reachable by any URL, resulting in code execution or source code disclosure. 

Substitutions in server context that use a backreferences or variables as the first segment of the substitution are affected.  Some unsafe RewiteRules will be broken by this change and the rewrite flag "UnsafePrefixStat" can be used to opt back in once ensuring the substitution is appropriately constrained.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-38475?

1 open source package ship an affected version, including apache. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.60 |

Products: Apache Http Server, Netapp Ontap 9, Sonicwall Sma 200 Firmware, Sonicwall Sma 210 Firmware, Sonicwall Sma 400 Firmware, Sonicwall Sma 410 Firmware, Sonicwall Sma 500v Firmware.

## How do I fix CVE-2024-38475?

Upgrade apache to 2.4.60 or later. US federal agencies must fix it by 22 May 2025.

## Is CVE-2024-38475 being exploited?

Yes. Attackers have exploited CVE-2024-38475 in the wild since at least 1 May 2025.

Public exploit code:

- https://github.com/p0in7s/CVE-2024-38475 (github_poc): https://github.com/p0in7s/CVE-2024-38475
- exploit CVE-2024-38475(mod_rewrite weakness with filesystem path matching) (github_poc): https://github.com/soltanali0/CVE-2024-38475
- https://github.com/abrewer251/CVE-2024-38475_SonicBoom_Apache_URL_Traversal_PoC (github_poc): https://github.com/abrewer251/CVE-2024-38475_SonicBoom_Apache_URL_Traversal_PoC
- CVE-2024-38475 Scanner using FFUF + Seclists (github_poc): https://github.com/syaifulandy/CVE-2024-38475
- CVE-2024-38475 exploitation & scanning tool with Mullvad VPN rotation (github_poc): https://github.com/Nyakki-Labs-0x420/Myesve
- CVE-2024-38475 (github_poc): https://github.com/akabul0us/apache_poc

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)
- [CVE-2010-0425](https://insights.sbomify.com/CVE-2010-0425/): Use after free in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38475 and fix it if it is affected.

What it is: CVE-2024-38475 is a critical path traversal vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2024-38475 in the wild since at least 1 May 2025.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38475/ (Markdown: https://insights.sbomify.com/CVE-2024-38475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38475
- OSV: https://osv.dev/vulnerability/CVE-2024-38475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38475/
Summaries are generated and may contain mistakes; the official description above is the record.
