CVE-2024-38477 Apache HTTP Server: Crash resulting in Denial of Service in mod_proxy via a malicious request
An attacker can crash the Apache HTTP Server via a malicious request due to a null pointer dereference in mod_proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-38477?
CVE-2024-38477 is a high-severity vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Weakness: CWE-476
Which versions are affected by CVE-2024-38477?
1 open source package ship an affected version, including apache. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.60 |
Products include Apache Http Server, Netapp Clustered Data Ontap.
How do I fix CVE-2024-38477?
Upgrade apache to 2.4.60 or later.
Is CVE-2024-38477 being exploited?
There is no known exploitation of CVE-2024-38477 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2024-38477, BELL-CVE-2024-38477, BIT-apache-2024-38477, CLEANSTART-2026-XP17348, CLSA-2024-1725012024, CLSA-2024-1725012055 and 4 more.