# CVE-2024-38477: Apache HTTP Server: Crash resulting in Denial of Service in mod_proxy via a malicious request

> An attacker can crash the Apache HTTP Server via a malicious request due to a null pointer dereference in mod_proxy.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2024-38477, BELL-CVE-2024-38477, BIT-apache-2024-38477, CLEANSTART-2026-XP17348, CLSA-2024-1725012024, CLSA-2024-1725012055, CLSA-2025-1761747106, DEBIAN-CVE-2024-38477, GHSA-phjg-7fch-3c2f, UBUNTU-CVE-2024-38477

## What is CVE-2024-38477?

CVE-2024-38477 is a high-severity vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2024-38477?

1 open source package ship an affected version, including apache. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.60 |

Products: Apache Http Server, Netapp Clustered Data Ontap.

## How do I fix CVE-2024-38477?

Upgrade apache to 2.4.60 or later.

## Is CVE-2024-38477 being exploited?

There is no known exploitation of CVE-2024-38477 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38477 and fix it if it is affected.

What it is: CVE-2024-38477 is a high-severity vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-38477 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38477/ (Markdown: https://insights.sbomify.com/CVE-2024-38477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38477
- OSV: https://osv.dev/vulnerability/CVE-2024-38477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38477/
Summaries are generated and may contain mistakes; the official description above is the record.
