CVE-2024-38503 Apache Syncope: HTML tags can be injected into Console or Enduser text fields

Low 3.9 Published Updated

Attackers can inject HTML tags into Syncope Console or Enduser text fields, potentially leading to script execution and account compromise.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-38503?

CVE-2024-38503 is a low-severity cross-site scripting vulnerability in Apache Syncope, published on 22 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing “Personal Information” or “User Requests”.

Users are recommended to upgrade to version 3.0.8, which fixes this issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-38503?

4 open source packages ship an affected version, including org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui and org.apache.syncope.client.idrepo:syncope-client-idrepo-console. It affects 1 product.

PackageAffectedFixed in
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui MavenFrom 2.1.03.0.8
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui MavenFrom 2.1.03.0.8
org.apache.syncope.client.idrepo:syncope-client-idrepo-console MavenFrom 2.1.03.0.8
org.apache.syncope.client.idrepo:syncope-client-idrepo-console MavenFrom 2.1.03.0.8

Products include Apache Syncope.

How do I fix CVE-2024-38503?

Upgrade org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui to 3.0.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-38503 being exploited?

There is no known exploitation of CVE-2024-38503 in the wild and no public exploit code.

Sources

Also known as GHSA-8pxv-x6jq-5vw9.

Is CVE-2024-38503 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free