CVE-2024-38528 Unlimited number of NTS-KE connections can crash ntpd-rs server
An unauthenticated remote attacker can crash the ntpd-rs server by exhausting resources with unlimited NTS-KE connections, affecting only NTS-KE server configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-38528?
CVE-2024-38528 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. There is a missing limit for accepted NTS-KE connections. This allows an unauthenticated remote attacker to crash ntpd-rs when an NTS-KE server is configured. Non NTS-KE server configurations, such as the default ntpd-rs configuration, are unaffected. This vulnerability has been patched in version 1.1.3.
Weakness: CWE-770
Which versions are affected by CVE-2024-38528?
2 open source packages ship an affected version, including ntpd.
| Package | Affected | Fixed in |
|---|---|---|
ntpd crates.io | From 0.3.1 | 1.1.3 |
ntpd crates.io | From 0.3.1 | 1.1.3 |
Linux distribution packages (5)
ntpd-rs SUSE:Package Hub 15 SP5 | All versions | 1.2.3-bp155.2.1 |
ntpd-rs SUSE:Package Hub 15 SP6 | All versions | 1.2.3-bp156.2.1 |
ntpd-rs openSUSE:Leap 15.5 | All versions | 1.2.3-bp155.2.1 |
ntpd-rs openSUSE:Leap 15.6 | All versions | 1.2.3-bp156.2.1 |
ntpd-rs openSUSE:Tumbleweed | All versions | 1.2.0-1.1 |
How do I fix CVE-2024-38528?
Upgrade ntpd to 1.1.3 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-38528 being exploited?
There is no known exploitation of CVE-2024-38528 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2024-38528, GHSA-2xpx-vcmq-5f72, UBUNTU-CVE-2024-38528, openSUSE-SU-2024:0300-1, openSUSE-SU-2024:0331-1, openSUSE-SU-2024:14194-1.