{"answers":{"affected":"2 open source packages ship an affected version, including ntpd.","exploited":"There is no known exploitation of CVE-2024-38528 in the wild and no public exploit code.","fix":"Upgrade ntpd to 1.1.3 or later.","what":"CVE-2024-38528 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38528 and fix it if it is affected.\n\nWhat it is: CVE-2024-38528 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-38528 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ntpd (crates.io): affected from 0.3.1; fixed in 1.1.3\n- ntpd (crates.io): affected from 0.3.1; fixed in 1.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38528/ (Markdown: https://insights.sbomify.com/CVE-2024-38528/index.md)","id":"CVE-2024-38528","markdown":"https://insights.sbomify.com/CVE-2024-38528/index.md","name":"CVE-2024-38528","record":{"aliases":["DEBIAN-CVE-2024-38528","GHSA-2xpx-vcmq-5f72","UBUNTU-CVE-2024-38528","openSUSE-SU-2024:0300-1","openSUSE-SU-2024:0331-1","openSUSE-SU-2024:14194-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NTP time synchronization server","requires_auth":"none","summary":"An unauthenticated remote attacker can crash the ntpd-rs server by exhausting resources with unlimited NTS-KE connections, affecting only NTS-KE server configurations.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. There is a missing limit for accepted NTS-KE connections. This allows an unauthenticated remote attacker to crash ntpd-rs when an NTS-KE server is configured. Non NTS-KE server configurations, such as the default ntpd-rs configuration, are unaffected. This vulnerability has been patched in version 1.1.3.","ecosystems":["SUSE:Package Hub 15 SP5","SUSE:Package Hub 15 SP6","crates.io","openSUSE:Leap 15.5","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unlimited number of NTS-KE connections can crash ntpd-rs server","id":"CVE-2024-38528","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":7,"n_references":1,"next":{"headline":"Admidio Vulnerable to RCE via Arbitrary File Upload in Message Attachment","id":"CVE-2024-38529"},"packages":[{"ecosystem":"crates.io","fixed":["1.1.3"],"introduced":["0.3.1"],"last_affected":[],"package":"ntpd","purl":null,"source":"GHSA-2xpx-vcmq-5f72"},{"ecosystem":"crates.io","fixed":["1.1.3"],"introduced":["0.3.1"],"last_affected":[],"package":"ntpd","purl":"pkg:cargo/ntpd","source":"GHSA-2xpx-vcmq-5f72"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["1.2.3-bp155.2.1"],"introduced":["0"],"last_affected":[],"package":"ntpd-rs","purl":"pkg:rpm/suse/ntpd-rs\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0331-1"},{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["1.2.3-bp156.2.1"],"introduced":["0"],"last_affected":[],"package":"ntpd-rs","purl":"pkg:rpm/suse/ntpd-rs\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2024:0300-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["1.2.3-bp155.2.1"],"introduced":["0"],"last_affected":[],"package":"ntpd-rs","purl":"pkg:rpm/opensuse/ntpd-rs\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0331-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["1.2.3-bp156.2.1"],"introduced":["0"],"last_affected":[],"package":"ntpd-rs","purl":"pkg:rpm/opensuse/ntpd-rs\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2024:0300-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.0-1.1"],"introduced":["0"],"last_affected":[],"package":"ntpd-rs","purl":"pkg:rpm/opensuse/ntpd-rs\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14194-1"}],"prev":{"headline":"Cross-site Scripting in ZenUML","id":"CVE-2024-38527"},"products":["ntpd-rs"],"published":"2024-06-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["pendulum-project"]},"summary":"An unauthenticated remote attacker can crash the ntpd-rs server by exhausting resources with unlimited NTS-KE connections, affecting only NTS-KE server configurations.","url":"https://insights.sbomify.com/CVE-2024-38528/"}