# CVE-2024-38528: Unlimited number of NTS-KE connections can crash ntpd-rs server

> An unauthenticated remote attacker can crash the ntpd-rs server by exhausting resources with unlimited NTS-KE connections, affecting only NTS-KE server configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-38528, GHSA-2xpx-vcmq-5f72, UBUNTU-CVE-2024-38528, openSUSE-SU-2024:0300-1, openSUSE-SU-2024:0331-1, openSUSE-SU-2024:14194-1

## What is CVE-2024-38528?

CVE-2024-38528 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. There is a missing limit for accepted NTS-KE connections. This allows an unauthenticated remote attacker to crash ntpd-rs when an NTS-KE server is configured. Non NTS-KE server configurations, such as the default ntpd-rs configuration, are unaffected. This vulnerability has been patched in version 1.1.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-38528?

2 open source packages ship an affected version, including ntpd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ntpd` | crates.io | From 0.3.1 | 1.1.3 |
| `ntpd` | crates.io | From 0.3.1 | 1.1.3 |
| `ntpd-rs` | SUSE:Package Hub 15 SP5 | All versions | 1.2.3-bp155.2.1 |
| `ntpd-rs` | SUSE:Package Hub 15 SP6 | All versions | 1.2.3-bp156.2.1 |
| `ntpd-rs` | openSUSE:Leap 15.5 | All versions | 1.2.3-bp155.2.1 |
| `ntpd-rs` | openSUSE:Leap 15.6 | All versions | 1.2.3-bp156.2.1 |
| `ntpd-rs` | openSUSE:Tumbleweed | All versions | 1.2.0-1.1 |

## How do I fix CVE-2024-38528?

Upgrade ntpd to 1.1.3 or later.

## Is CVE-2024-38528 being exploited?

There is no known exploitation of CVE-2024-38528 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38528 and fix it if it is affected.

What it is: CVE-2024-38528 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-38528 in the wild and no public exploit code.

Affected packages and fixed versions:
- ntpd (crates.io): affected from 0.3.1; fixed in 1.1.3
- ntpd (crates.io): affected from 0.3.1; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38528/ (Markdown: https://insights.sbomify.com/CVE-2024-38528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38528
- OSV: https://osv.dev/vulnerability/CVE-2024-38528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38528/
Summaries are generated and may contain mistakes; the official description above is the record.
