{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-38537 in the wild and no public exploit code.","fix":"Upgrade ethyca-fides to 2.39.1 or later.","what":"CVE-2024-38537 is a vulnerability in ethyca fides, published on 2 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38537 and fix it if it is affected.\n\nWhat it is: CVE-2024-38537 is a vulnerability in ethyca fides, published on 2 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-38537 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected all versions; fixed in 2.39.1\n- ethyca-fides (PyPI): affected all versions; fixed in 2.39.1\n- ethyca-fides (PyPI): affected all versions; fixed in 2.39.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38537/ (Markdown: https://insights.sbomify.com/CVE-2024-38537/index.md)","id":"CVE-2024-38537","markdown":"https://insights.sbomify.com/CVE-2024-38537/index.md","name":"CVE-2024-38537","record":{"aliases":["GHSA-cvw4-c69g-7v7m","PYSEC-2026-1339"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Privacy consent script","requires_auth":"none","summary":"Attackers could execute malicious code on legacy browsers via compromised polyfill.io dependency in Fides consent script.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fides","vendor":"ethyca"}],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"Fides is an open-source privacy engineering platform. `fides.js`, a client-side script used to interact with the consent management features of Fides, used the `polyfill.io` domain in a very limited edge case, when it detected a legacy browser such as IE11 that did not support the fetch standard. Therefore it was possible for users of legacy, pre-2017 browsers who navigate to a page serving `fides.js` to download and execute malicious scripts from the `polyfill.io` domain when the domain was compromised and serving malware. No exploitation of `fides.js` via `polyfill.io` has been identified as of time of publication.\n\nThe vulnerability has been patched in Fides version `2.39.1`. Users are advised to upgrade to this version or later to secure their systems against this threat. On Thursday, June 27, 2024, Cloudflare and Namecheap intervened at a domain level to ensure `polyfill.io` and its subdomains could not resolve to the compromised service, rendering this vulnerability unexploitable. Prior to the domain level intervention, there were no server-side workarounds and the confidentiality, integrity, and availability impacts of this vulnerability were high. Clients could ensure they were not affected by using a modern browser that supported the fetch standard.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2024-07-07","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-07-07T15:06:39Z","kind":"github_poc","ref":"https://github.com/Havoc10-sw/Detect_polyfill_CVE-2024-38537-","stars":0,"title":"Here's a Python script that checks if the polyfill.io domain is present in the Content Security Policy (CSP) header of a given web application."}],"tier":"poc_unverified"},"has_fix":true,"headline":"Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js","id":"CVE-2024-38537","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2024"},"n_packages":3,"n_references":5,"next":{"headline":"net: bridge: xmit: make sure we have at least eth header len bytes","id":"CVE-2024-38538"},"packages":[{"ecosystem":"PyPI","fixed":["2.39.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-cvw4-c69g-7v7m"},{"ecosystem":"PyPI","fixed":["2.39.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-cvw4-c69g-7v7m"},{"ecosystem":"PyPI","fixed":["2.39.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2026-1339"}],"prev":{"headline":"Suricata http/range: NULL-ptr deref when http.memcap is reached","id":"CVE-2024-38536"},"products":["fides"],"published":"2024-07-02","related":[{"cvss_score":9.1,"headline":"Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine","id":"CVE-2024-45053","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":8.8,"headline":"Remote Code Execution in Custom Integration Upload in Fides","id":"CVE-2023-41319","kev_date_added":null,"published":"2023-09-06"},{"cvss_score":8.6,"headline":"Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation","id":"CVE-2025-57817","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":8.2,"headline":"Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides","id":"CVE-2023-48224","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.2,"headline":"Server-Side Request Forgery Vulnerability in Custom Integration Upload","id":"CVE-2023-46124","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"Fides vulnerable to Path Traversal in Webserver API","id":"CVE-2023-36827","kev_date_added":null,"published":"2023-07-05"},{"cvss_score":6.5,"headline":"Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides","id":"CVE-2024-35189","kev_date_added":null,"published":"2024-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["ethyca"]},"summary":"Attackers could execute malicious code on legacy browsers via compromised polyfill.io dependency in Fides consent script.","url":"https://insights.sbomify.com/CVE-2024-38537/"}