# CVE-2024-38537: Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js

> Attackers could execute malicious code on legacy browsers via compromised polyfill.io dependency in Fides consent script.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cvw4-c69g-7v7m, PYSEC-2026-1339

## What is CVE-2024-38537?

CVE-2024-38537 is a vulnerability in ethyca fides, published on 2 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. `fides.js`, a client-side script used to interact with the consent management features of Fides, used the `polyfill.io` domain in a very limited edge case, when it detected a legacy browser such as IE11 that did not support the fetch standard. Therefore it was possible for users of legacy, pre-2017 browsers who navigate to a page serving `fides.js` to download and execute malicious scripts from the `polyfill.io` domain when the domain was compromised and serving malware. No exploitation of `fides.js` via `polyfill.io` has been identified as of time of publication.

The vulnerability has been patched in Fides version `2.39.1`. Users are advised to upgrade to this version or later to secure their systems against this threat. On Thursday, June 27, 2024, Cloudflare and Namecheap intervened at a domain level to ensure `polyfill.io` and its subdomains could not resolve to the compromised service, rendering this vulnerability unexploitable. Prior to the domain level intervention, there were no server-side workarounds and the confidentiality, integrity, and availability impacts of this vulnerability were high. Clients could ensure they were not affected by using a modern browser that supported the fetch standard.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2024-38537?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.39.1 |
| `ethyca-fides` | PyPI | All versions | 2.39.1 |
| `ethyca-fides` | PyPI | All versions | 2.39.1 |

Products: Ethyca Fides.

## How do I fix CVE-2024-38537?

Upgrade ethyca-fides to 2.39.1 or later.

## Is CVE-2024-38537 being exploited?

There is no known exploitation of CVE-2024-38537 in the wild and no public exploit code.

Public exploit code:

- Here's a Python script that checks if the polyfill.io domain is present in the Content Security Policy (CSP) header of a given web application. (github_poc): https://github.com/Havoc10-sw/Detect_polyfill_CVE-2024-38537-

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38537 and fix it if it is affected.

What it is: CVE-2024-38537 is a vulnerability in ethyca fides, published on 2 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-38537 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.39.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.39.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38537/ (Markdown: https://insights.sbomify.com/CVE-2024-38537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38537
- OSV: https://osv.dev/vulnerability/CVE-2024-38537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38537/
Summaries are generated and may contain mistakes; the official description above is the record.
