# CVE-2024-38828: CVE-2024-38828: DoS via Spring MVC controller method with byte[] parameter

> Attackers can cause denial of service in applications using Spring MVC controllers with byte array request bodies.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2024
- **Updated:** 9 May 2025
- **Also known as:** CLEANSTART-2026-NS04003, CLEANSTART-2026-UO20000, CLSA-2025-1743120048, CLSA-2026-1782954026, DEBIAN-CVE-2024-38828, ECHO-3f20-b6da-0d15, GHSA-w3c8-7r8f-9jp8, ROOT-APP-MAVEN-CVE-2024-38828, UBUNTU-CVE-2024-38828

## What is CVE-2024-38828?

CVE-2024-38828 is a medium-severity denial of service vulnerability in Spring, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring MVC controller methods with an @RequestBody byte[] method parameter are vulnerable to a DoS attack.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-38828?

2 open source packages ship an affected version, including org.springframework:spring-webmvc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-webmvc` | Maven | From 5.3.0 | 5.3.42 |
| `org.springframework:spring-webmvc` | Maven | From 5.3.0 | 5.3.42 |

## How do I fix CVE-2024-38828?

Upgrade org.springframework:spring-webmvc to 5.3.42 or later.

## Is CVE-2024-38828 being exploited?

There is no known exploitation of CVE-2024-38828 in the wild and no public exploit code.

Public exploit code:

- This demo application partially covers the vulnerability CVE-2024-38828 (github_poc): https://github.com/First-Roman/sprig-mvc-demo-patch
- CVE-2024-38828: DoS via Spring MVC controller method with byte[] parameter  (github_poc): https://github.com/topilov/axiom-jdk-test-task
- https://github.com/funcid/CVE-2024-38828 (github_poc): https://github.com/funcid/CVE-2024-38828

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38828 and fix it if it is affected.

What it is: CVE-2024-38828 is a medium-severity denial of service vulnerability in Spring, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-38828 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-webmvc (Maven): affected from 5.3.0; fixed in 5.3.42
- org.springframework:spring-webmvc (Maven): affected from 5.3.0; fixed in 5.3.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38828/ (Markdown: https://insights.sbomify.com/CVE-2024-38828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38828
- OSV: https://osv.dev/vulnerability/CVE-2024-38828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38828/
Summaries are generated and may contain mistakes; the official description above is the record.
