# CVE-2024-38856: Apache OFBiz Incorrect Authorization

> Unauthenticated attackers can execute screen rendering code in Apache OFBiz if specific screen definitions lack explicit permission checks.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Yes, since 27 Aug 2024 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2024
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-gp2r-34c8-48xq

## What is CVE-2024-38856?

CVE-2024-38856 is a high-severity missing authorization vulnerability in Apache Ofbiz, published on 5 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Apache OFBiz.

This issue affects Apache OFBiz: through 18.12.14.

Users are recommended to upgrade to version 18.12.15, which fixes the issue.

Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-38856?

It affects 1 product.


Products: Apache Ofbiz.

## How do I fix CVE-2024-38856?

No fix has been published for CVE-2024-38856 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 17 Sep 2024.

## Is CVE-2024-38856 being exploited?

Yes. Attackers have exploited CVE-2024-38856 in the wild since at least 27 Aug 2024.

Public exploit code:

- Apache OFBiz RCE Scanner & Exploit (CVE-2024-38856) (github_poc): https://github.com/securelayer7/CVE-2024-38856_Scanner
- CVE-2024-38856 Exploit (github_poc): https://github.com/0x20c/CVE-2024-38856-EXP
- Apache OFBiz CVE-2024-38856 (github_poc): https://github.com/BBD-YZZ/CVE-2024-38856-RCE
- CVE-2024-38856: Apache OFBiz remote code execution Scanner & Exploit (github_poc): https://github.com/Hex00-0x4/CVE-2024-38856-Apache-OFBiz
- Perform With Massive Apache OFBiz Zero-Day Scanner & RCE (github_poc): https://github.com/Ap0dexMe0/CVE-2024-38856
- Exploit for CVE-2024-38856 affecting Apache OFBiz versions before 18.12.15 (github_poc): https://github.com/GraySignal/CVE-2024-38856-ApacheOfBiz

## Other vulnerabilities in Apache Ofbiz

- [CVE-2024-45195](https://insights.sbomify.com/CVE-2024-45195/): Apache OFBiz Forced Browsing (critical 9.8, exploited in the wild)
- [CVE-2024-32113](https://insights.sbomify.com/CVE-2024-32113/): Apache OFBiz Path Traversal (critical 9.1, exploited in the wild)
- [CVE-2013-2250](https://insights.sbomify.com/CVE-2013-2250/): Code injection in n/a (critical 10.0)
- [CVE-2012-3506](https://insights.sbomify.com/CVE-2012-3506/): Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2026-45434](https://insights.sbomify.com/CVE-2026-45434/): Apache OFBiz: Authentication Bypass via Password-Change Logic Flaw Leading to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38856 and fix it if it is affected.

What it is: CVE-2024-38856 is a high-severity missing authorization vulnerability in Apache Ofbiz, published on 5 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2024-38856 in the wild since at least 27 Aug 2024.

Affected product: Apache Ofbiz. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38856/ (Markdown: https://insights.sbomify.com/CVE-2024-38856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38856
- OSV: https://osv.dev/vulnerability/CVE-2024-38856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38856/
Summaries are generated and may contain mistakes; the official description above is the record.
