CVE-2024-38875 Django vulnerable to Denial of Service

High 7.5 Published Updated

Attackers can cause denial of service in Django applications by providing inputs with excessive brackets to urlize functions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-38875?

CVE-2024-38875 is a high-severity denial of service vulnerability in Djangoproject Django, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Django 4.2 before 4.2.14 and 5.0 before 5.0.7. urlize and urlizetrunc were subject to a potential denial of service attack via certain inputs with a very large number of brackets.

Weakness: CWE-130

Which versions are affected by CVE-2024-38875?

6 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django BitnamiFrom 4.2.04.2.14, 5.0.7
django PyPIFrom 4.24.2.14, 5.0.7
django PyPIFrom 4.24.2.14
django PyPIFrom 5.05.0.7
Django PyPIFrom 4.24.2.14
Django PyPIFrom 5.05.0.7

Products include Djangoproject Django.

How do I fix CVE-2024-38875?

Upgrade django to a fixed version for your release line: 4.2.14 or 5.0.7.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-38875 being exploited?

There is no known exploitation of CVE-2024-38875 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as BIT-django-2024-38875, CLSA-2025-1757549494, DEBIAN-CVE-2024-38875, GHSA-qg2p-9jwr-mmqf, OESA-2024-1948, PYSEC-2024-56 and 1 more.

Is CVE-2024-38875 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free