CVE-2024-3895 WP Datepicker <= 2.1.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update

High 8.8 Published Updated

Authenticated subscribers can update arbitrary options due to missing capability checks, potentially leading to privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-3895?

CVE-2024-3895 is a high-severity missing authorization vulnerability in fahadmahmood WP Datepicker, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The WP Datepicker plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpdp_add_new_datepicker_ajax() function in all versions up to, and including, 2.1.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options that can be used for privilege escalation. This was partially patched in 2.0.9 and 2.1.0, and fully patched in 2.1.1.

Weakness: CWE-862

Which versions are affected by CVE-2024-3895?

It affects 1 product.

Products include Androidbubbles Wp Datepicker.

How do I fix CVE-2024-3895?

No fix has been published for CVE-2024-3895 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-3895 being exploited?

There is no known exploitation of CVE-2024-3895 in the wild and no public exploit code.

Sources

Also known as GHSA-6r8w-jhg7-gpr9.

Is CVE-2024-3895 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free