{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-3895 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-3895 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-3895 is a high-severity missing authorization vulnerability in fahadmahmood WP Datepicker, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-3895 and fix it if it is affected.\n\nWhat it is: CVE-2024-3895 is a high-severity missing authorization vulnerability in fahadmahmood WP Datepicker, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-3895 in the wild and no public exploit code.\n\nAffected product: fahadmahmood WP Datepicker. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3895/ (Markdown: https://insights.sbomify.com/CVE-2024-3895/index.md)","id":"CVE-2024-3895","markdown":"https://insights.sbomify.com/CVE-2024-3895/index.md","name":"CVE-2024-3895","record":{"aliases":["GHSA-6r8w-jhg7-gpr9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can update arbitrary options due to missing capability checks, potentially leading to privilege escalation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wp_datepicker","vendor":"androidbubbles"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The WP Datepicker plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpdp_add_new_datepicker_ajax() function in all versions up to, and including, 2.1.0. This makes it possible for authenticated attackers, with  subscriber-level access and above, to update arbitrary options that can be used for privilege escalation. This was partially patched in 2.0.9 and 2.1.0, and fully patched in 2.1.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WP Datepicker \u003c= 2.1.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update","id":"CVE-2024-3895","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Cross-site scripting in Robo Gallery – Photo \u0026 Image Slider","id":"CVE-2024-3896"},"packages":[],"prev":{"headline":"Cross-site scripting in Robo Gallery – Photo \u0026 Image Slider","id":"CVE-2024-3894"},"products":["WP Datepicker"],"published":"2024-05-02","related":[{"cvss_score":6.5,"headline":"WordPress WP Datepicker plugin \u003c= 2.1.1 - Broken Access Control vulnerability","id":"CVE-2024-47321","kev_date_added":null,"published":"2024-11-01"},{"cvss_score":6.1,"headline":"WP Datepicker \u003c= 2.1.4 - Reflected Cross-Site Scripting","id":"CVE-2024-12468","kev_date_added":null,"published":"2024-12-24"},{"cvss_score":5.9,"headline":"WordPress WP Datepicker plugin \u003c= 2.1.1 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-44042","kev_date_added":null,"published":"2024-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["fahadmahmood"]},"summary":"Authenticated subscribers can update arbitrary options due to missing capability checks, potentially leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2024-3895/"}