CVE-2024-38988 @alizeait/unflatto Prototype Pollution

Critical 9.8 Published Updated

Attackers can execute arbitrary code or cause denial of service via prototype pollution in the unflatto library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-38988?

CVE-2024-38988 is a critical code injection vulnerability in n/a, published on 28 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

alizeait unflatto <= 1.0.2 was discovered to contain a prototype pollution via the method exports.unflatto at /dist/index.js. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Weakness: CWE-1321

Which versions are affected by CVE-2024-38988?

2 open source packages ship an affected version, including @alizeait/unflatto. It affects 1 product.

PackageAffectedFixed in
@alizeait/unflatto npmAll versions1.0.3
@alizeait/unflatto npmAll versions1.0.3

Products include Alizeait Unflatto.

How do I fix CVE-2024-38988?

Upgrade @alizeait/unflatto to 1.0.3 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-38988 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38988 exists.

Sources

Also known as GHSA-q8jq-4rm5-4hm5.

Is CVE-2024-38988 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free