{"answers":{"affected":"4 open source packages ship an affected version, including ag-grid-community and ag-grid-enterprise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38996 exists.","fix":"Upgrade ag-grid-community to 31.3.4 or later.","what":"CVE-2024-38996 is a critical code injection vulnerability in n/a, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38996 and fix it if it is affected.\n\nWhat it is: CVE-2024-38996 is a critical code injection vulnerability in n/a, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38996 exists.\n\nAffected packages and fixed versions:\n- ag-grid-community (npm): affected all versions; fixed in 31.3.4\n- ag-grid-community (npm): affected all versions; fixed in 31.3.4\n- ag-grid-enterprise (npm): affected all versions; fixed in 31.3.4\n- ag-grid-enterprise (npm): affected all versions; fixed in 31.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38996/ (Markdown: https://insights.sbomify.com/CVE-2024-38996/index.md)","id":"CVE-2024-38996","markdown":"https://insights.sbomify.com/CVE-2024-38996/index.md","name":"CVE-2024-38996","record":{"aliases":["GHSA-876p-c77m-x2hc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript grid library","requires_auth":"none","summary":"Attackers can execute arbitrary code or cause denial of service via prototype pollution in the ag-grid library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ag-grid","vendor":"ag-grid"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"ag-grid-community v31.3.2 and ag-grid-enterprise v31.3.2 were discovered to contain a prototype pollution via the _.mergeDeep function. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Prototype pollution in ag-grid-community via the _.mergeDeep function","id":"CVE-2024-38996","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"adolph_dudu ratio-swiper was discovered to contain a prototype pollution via the function extendDefaults","id":"CVE-2024-38997"},"packages":[{"ecosystem":"npm","fixed":["31.3.4"],"introduced":["0"],"last_affected":[],"package":"ag-grid-community","purl":null,"source":"GHSA-876p-c77m-x2hc"},{"ecosystem":"npm","fixed":["31.3.4"],"introduced":["0"],"last_affected":[],"package":"ag-grid-community","purl":"pkg:npm/ag-grid-community","source":"GHSA-876p-c77m-x2hc"},{"ecosystem":"npm","fixed":["31.3.4"],"introduced":["0"],"last_affected":[],"package":"ag-grid-enterprise","purl":null,"source":"GHSA-876p-c77m-x2hc"},{"ecosystem":"npm","fixed":["31.3.4"],"introduced":["0"],"last_affected":[],"package":"ag-grid-enterprise","purl":"pkg:npm/ag-grid-enterprise","source":"GHSA-876p-c77m-x2hc"}],"prev":{"headline":"@amoy/common v was discovered to contain a prototype pollution via the function extend","id":"CVE-2024-38994"},"products":["n/a"],"published":"2024-07-01","related":[{"cvss_score":6.3,"headline":"ag-grid packages vulnerable to Prototype Pollution","id":"CVE-2024-39001","kev_date_added":null,"published":"2024-07-01"},{"cvss_score":6.1,"headline":"XSS via Angular Expression in ag-grid","id":"CVE-2017-16009","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code or cause denial of service via prototype pollution in the ag-grid library.","url":"https://insights.sbomify.com/CVE-2024-38996/"}