{"answers":{"affected":"2 open source packages ship an affected version, including requirejs.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38999 exists.","fix":"Upgrade requirejs to 2.3.7 or later.","what":"CVE-2024-38999 is a critical code injection vulnerability in n/a, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38999 and fix it if it is affected.\n\nWhat it is: CVE-2024-38999 is a critical code injection vulnerability in n/a, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38999 exists.\n\nAffected packages and fixed versions:\n- requirejs (npm): affected all versions; fixed in 2.3.7\n- requirejs (npm): affected all versions; fixed in 2.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38999/ (Markdown: https://insights.sbomify.com/CVE-2024-38999/index.md)","id":"CVE-2024-38999","markdown":"https://insights.sbomify.com/CVE-2024-38999/index.md","name":"CVE-2024-38999","record":{"aliases":["CLSA-2026-1773706623","CLSA-2026-1774311625","DEBIAN-CVE-2024-38999","GHSA-x3m3-4wpv-5vgc","OESA-2026-1600","UBUNTU-CVE-2024-38999"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript module loader","requires_auth":"none","summary":"Attackers can execute arbitrary code or cause denial of service via prototype pollution in the RequireJS library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function s.contexts._.configure. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"jrburke requirejs vulnerable to prototype pollution","id":"CVE-2024-38999","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Code injection in n/a","id":"CVE-2024-39000"},"packages":[{"ecosystem":"npm","fixed":["2.3.7"],"introduced":["0"],"last_affected":[],"package":"requirejs","purl":null,"source":"GHSA-x3m3-4wpv-5vgc"},{"ecosystem":"npm","fixed":["2.3.7"],"introduced":["0"],"last_affected":[],"package":"requirejs","purl":"pkg:npm/requirejs","source":"GHSA-x3m3-4wpv-5vgc"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2024-38998"},"products":["n/a"],"published":"2024-07-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code or cause denial of service via prototype pollution in the RequireJS library.","url":"https://insights.sbomify.com/CVE-2024-38999/"}