# CVE-2024-38999: jrburke requirejs vulnerable to prototype pollution

> Attackers can execute arbitrary code or cause denial of service via prototype pollution in the RequireJS library.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** CLSA-2026-1773706623, CLSA-2026-1774311625, DEBIAN-CVE-2024-38999, GHSA-x3m3-4wpv-5vgc, OESA-2026-1600, UBUNTU-CVE-2024-38999

## What is CVE-2024-38999?

CVE-2024-38999 is a critical code injection vulnerability in n/a, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function s.contexts._.configure. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-38999?

2 open source packages ship an affected version, including requirejs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `requirejs` | npm | All versions | 2.3.7 |
| `requirejs` | npm | All versions | 2.3.7 |

## How do I fix CVE-2024-38999?

Upgrade requirejs to 2.3.7 or later.

## Is CVE-2024-38999 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38999 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38999 and fix it if it is affected.

What it is: CVE-2024-38999 is a critical code injection vulnerability in n/a, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38999 exists.

Affected packages and fixed versions:
- requirejs (npm): affected all versions; fixed in 2.3.7
- requirejs (npm): affected all versions; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38999/ (Markdown: https://insights.sbomify.com/CVE-2024-38999/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38999
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38999
- OSV: https://osv.dev/vulnerability/CVE-2024-38999

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38999/
Summaries are generated and may contain mistakes; the official description above is the record.
