CVE-2024-39274 Malicious remote can add users to arbitrary teams and channels

High 8.7 Published Updated

A malicious remote user can add users to arbitrary teams and channels due to insufficient validation of shared channel status.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-39274?

CVE-2024-39274 is a high-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5 and 9.8.x <= 9.8.1 fail to properly validate that the channel that comes from the sync message is a shared channel, when shared channels are enabled, which allows a malicious remote to add users to arbitrary teams and channels

Weakness: CWE-284

Which versions are affected by CVE-2024-39274?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.7.09.7.6
github.com/mattermost/mattermost/server/v8 GoFrom 9.7.09.7.6
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost.

How do I fix CVE-2024-39274?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7, 9.7.6, 9.8.2 or 9.9.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-39274 being exploited?

There is no known exploitation of CVE-2024-39274 in the wild and no public exploit code.

All Mattermost Mattermost vulnerabilities

Sources

Also known as GHSA-cmc8-222c-vqp9, GO-2024-3028.

Is CVE-2024-39274 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free