# CVE-2024-39274: Malicious remote can add users to arbitrary teams and channels

> A malicious remote user can add users to arbitrary teams and channels due to insufficient validation of shared channel status.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cmc8-222c-vqp9, GO-2024-3028

## What is CVE-2024-39274?

CVE-2024-39274 is a high-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5 and 9.8.x <= 9.8.1 fail to properly validate that the channel that comes from the sync message is a shared channel, when shared channels are enabled, which allows a malicious remote to add users to arbitrary teams and channels

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-39274?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.7 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.7 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.7.0 | 9.7.6 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.7.0 | 9.7.6 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.8.0 | 9.8.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.8.0 | 9.8.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.9.0 | 9.9.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.9.0 | 9.9.1 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0+incompatible | 9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost.

## How do I fix CVE-2024-39274?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7, 9.7.6, 9.8.2 or 9.9.1.

## Is CVE-2024-39274 being exploited?

There is no known exploitation of CVE-2024-39274 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost

- [CVE-2019-20851](https://insights.sbomify.com/CVE-2019-20851/): Path traversal in n/a (critical 9.1)
- [CVE-2024-39777](https://insights.sbomify.com/CVE-2024-39777/): Malicious remote can invite itself to an arbitrary local channel (high 8.7)
- [CVE-2024-39830](https://insights.sbomify.com/CVE-2024-39830/): Timing attack during remote cluster token comparison when shared channels are enabled (high 8.1)
- [CVE-2023-3615](https://insights.sbomify.com/CVE-2023-3615/): Lack of server certificate validation in websockets connection (high 8.1)
- [CVE-2020-13891](https://insights.sbomify.com/CVE-2020-13891/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39274 and fix it if it is affected.

What it is: CVE-2024-39274 is a high-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39274 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.7
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.7
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.7.0; fixed in 9.7.6
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.7.0; fixed in 9.7.6
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.8.0; fixed in 9.8.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.8.0; fixed in 9.8.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.9.0; fixed in 9.9.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.9.0; fixed in 9.9.1
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0+incompatible; fixed in 9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39274/ (Markdown: https://insights.sbomify.com/CVE-2024-39274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39274
- OSV: https://osv.dev/vulnerability/CVE-2024-39274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39274/
Summaries are generated and may contain mistakes; the official description above is the record.
