# CVE-2024-39303: Weblate vulnerabler to improper sanitization of project backups


- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jfgp-674x-6q4p, PYSEC-2026-2041, openSUSE-SU-2024:14210-1

## What is CVE-2024-39303?

CVE-2024-39303 is a medium-severity vulnerability in WeblateOrg weblate, published on 1 Jul 2024. 

### Official description

Weblate is a web based localization tool. Prior to version 5.6.2, Weblate didn't correctly validate filenames when restoring project backup. It may be possible to gain unauthorized access to files on the server using a crafted ZIP file. This issue has been addressed in Weblate 5.6.2. As a workaround, do not allow untrusted users to create projects.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2024-39303?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | From 4.14 | 5.6.2 |
| `weblate` | PyPI | From 4.14 | 5.6.2 |
| `Weblate` | PyPI | From 4.14 | 5.6.2 |
| `weblate` | openSUSE:Tumbleweed | All versions | 5.6.2-1.1 |

Products: Weblate Weblate.

## How do I fix CVE-2024-39303?

Upgrade weblate to 5.6.2 or later.

## Is CVE-2024-39303 being exploited?

There is no known exploitation of CVE-2024-39303 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39303 and fix it if it is affected.

What it is: CVE-2024-39303 is a medium-severity vulnerability in WeblateOrg weblate, published on 1 Jul 2024. 
Exploitation: There is no known exploitation of CVE-2024-39303 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected from 4.14; fixed in 5.6.2
- weblate (PyPI): affected from 4.14; fixed in 5.6.2
- Weblate (PyPI): affected from 4.14; fixed in 5.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39303/ (Markdown: https://insights.sbomify.com/CVE-2024-39303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39303
- OSV: https://osv.dev/vulnerability/CVE-2024-39303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39303/
Summaries are generated and may contain mistakes; the official description above is the record.
