CVE-2024-39308 RailsAdmin Cross-site Scripting vulnerability in the list view
Attackers can execute arbitrary scripts in the RailsAdmin list view via unescaped HTML title attributes, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-39308?
CVE-2024-39308 is a medium-severity cross-site scripting vulnerability in railsadminteam rails_admin, published on 8 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).
Weakness: CWE-79
Which versions are affected by CVE-2024-39308?
2 open source packages ship an affected version, including rails_admin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rails_admin RubyGems | From 3.0.0.beta | 3.1.3 |
rails_admin RubyGems | From 3.0.0.beta | 3.1.3 |
Products include Rails Admin Project Rails Admin.
How do I fix CVE-2024-39308?
Upgrade rails_admin to 3.1.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-39308 being exploited?
There is no known exploitation of CVE-2024-39308 in the wild and no public exploit code.
Other vulnerabilities in railsadminteam rails_admin
Sources
Also known as GHSA-8qgm-g2vv-vwvc, UBUNTU-CVE-2024-39308.