# CVE-2024-39308: RailsAdmin Cross-site Scripting vulnerability in the list view

> Attackers can execute arbitrary scripts in the RailsAdmin list view via unescaped HTML title attributes, potentially compromising user sessions.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8qgm-g2vv-vwvc, UBUNTU-CVE-2024-39308

## What is CVE-2024-39308?

CVE-2024-39308 is a medium-severity cross-site scripting vulnerability in railsadminteam rails_admin, published on 8 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-39308?

2 open source packages ship an affected version, including rails_admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails_admin` | RubyGems | From 3.0.0.beta | 3.1.3 |
| `rails_admin` | RubyGems | From 3.0.0.beta | 3.1.3 |

Products: Rails Admin Project Rails Admin.

## How do I fix CVE-2024-39308?

Upgrade rails_admin to 3.1.3 or later.

## Is CVE-2024-39308 being exploited?

There is no known exploitation of CVE-2024-39308 in the wild and no public exploit code.

## Other vulnerabilities in railsadminteam rails_admin

- [CVE-2016-10522](https://insights.sbomify.com/CVE-2016-10522/): Cross-site request forgery in rails_admin (high 8.8)
- [CVE-2020-36190](https://insights.sbomify.com/CVE-2020-36190/): rails_admin ruby gem XSS vulnerability (medium 6.1)
- [CVE-2017-12098](https://insights.sbomify.com/CVE-2017-12098/): rails_admin ruby gem XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39308 and fix it if it is affected.

What it is: CVE-2024-39308 is a medium-severity cross-site scripting vulnerability in railsadminteam rails_admin, published on 8 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39308 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails_admin (RubyGems): affected from 3.0.0.beta; fixed in 3.1.3
- rails_admin (RubyGems): affected from 3.0.0.beta; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39308/ (Markdown: https://insights.sbomify.com/CVE-2024-39308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39308
- OSV: https://osv.dev/vulnerability/CVE-2024-39308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39308/
Summaries are generated and may contain mistakes; the official description above is the record.
