CVE-2024-39309 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability
SQL injection in Parse Server with PostgreSQL allows attackers to read or modify data, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-39309?
CVE-2024-39309 is a critical SQL injection vulnerability in parse-community parse-server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A vulnerability in versions prior to 6.5.7 and 7.1.0 allows SQL injection when Parse Server is configured to use the PostgreSQL database. The algorithm to detect SQL injection has been improved in versions 6.5.7 and 7.1.0. No known workarounds are available.
Which versions are affected by CVE-2024-39309?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 6.5.7 |
parse-server npm | All versions | 6.5.7 |
parse-server npm | From 7.0.0 | 7.1.0 |
parse-server npm | From 7.0.0 | 7.1.0 |
parse Bitnami | All versions | 7.2.0 |
How do I fix CVE-2024-39309?
Upgrade parse-server to a fixed version for your release line: 6.5.7 or 7.1.0.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2024-39309 being exploited?
There is no known exploitation of CVE-2024-39309 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as BIT-parse-2024-39309, GHSA-c2hr-cqg6-8j6r.