{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse.","exploited":"There is no known exploitation of CVE-2024-39309 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 6.5.7 or 7.1.0.","what":"CVE-2024-39309 is a critical SQL injection vulnerability in parse-community parse-server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39309 and fix it if it is affected.\n\nWhat it is: CVE-2024-39309 is a critical SQL injection vulnerability in parse-community parse-server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-39309 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 6.5.7\n- parse-server (npm): affected all versions; fixed in 6.5.7\n- parse-server (npm): affected from 7.0.0; fixed in 7.1.0\n- parse-server (npm): affected from 7.0.0; fixed in 7.1.0\n- parse (Bitnami): affected all versions; fixed in 7.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39309/ (Markdown: https://insights.sbomify.com/CVE-2024-39309/index.md)","id":"CVE-2024-39309","markdown":"https://insights.sbomify.com/CVE-2024-39309/index.md","name":"CVE-2024-39309","record":{"aliases":["BIT-parse-2024-39309","GHSA-c2hr-cqg6-8j6r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"none","summary":"SQL injection in Parse Server with PostgreSQL allows attackers to read or modify data, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A vulnerability in versions prior to 6.5.7 and 7.1.0 allows SQL injection when Parse Server is configured to use the PostgreSQL database. The algorithm to detect SQL injection has been improved in versions 6.5.7 and 7.1.0. No known workarounds are available.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":"2025-10-07","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-10-07T19:31:01Z","kind":"github_poc","ref":"https://github.com/HeavyGhost-le/POC_SQL_injection_in_Parse_Server_prior_6.5.7_-_7.1.0","stars":2,"title":"Advanced PostgreSQL database enumeration tool exploiting CVE-2024-39309 in Parse Server - Comprehensive SQL injection exploitation for security research"}],"tier":"poc_unverified"},"has_fix":true,"headline":"ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability","id":"CVE-2024-39309","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":5,"n_references":5,"next":{"headline":"WordPress Basil Theme Authenticated (Contributor+) Persistent Cross-Site Scripting Vulnerability","id":"CVE-2024-39310"},"packages":[{"ecosystem":"Bitnami","fixed":["7.2.0"],"introduced":["0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2024-39309"},{"ecosystem":"npm","fixed":["6.5.7"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-c2hr-cqg6-8j6r"},{"ecosystem":"npm","fixed":["6.5.7"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-c2hr-cqg6-8j6r"},{"ecosystem":"npm","fixed":["7.1.0"],"introduced":["7.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-c2hr-cqg6-8j6r"},{"ecosystem":"npm","fixed":["7.1.0"],"introduced":["7.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-c2hr-cqg6-8j6r"}],"prev":{"headline":"RailsAdmin Cross-site Scripting vulnerability in the list view","id":"CVE-2024-39308"},"products":["parse-server"],"published":"2024-07-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["parse-community"]},"summary":"SQL injection in Parse Server with PostgreSQL allows attackers to read or modify data, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2024-39309/"}