CVE-2024-3931 Totara LMS User Selector check.php cross site scripting
Remote attackers can inject malicious scripts via the ID Number argument in Totara LMS, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2024-3931?
CVE-2024-3931 is a medium-severity cross-site scripting vulnerability in Totara LMS, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in Totara LMS up to 18.7. It has been rated as problematic. Affected by this issue is some unknown functionality of the file admin/roles/check.php of the component User Selector. The manipulation of the argument ID Number leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.
Which versions are affected by CVE-2024-3931?
It affects 1 product.
Products include Totara Totara.
How do I fix CVE-2024-3931?
No fix has been published for CVE-2024-3931 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-3931 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3931 exists.
Sources
Also known as GHSA-94h5-8cv5-pxxm.