{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3931 exists.","fix":"No fix has been published for CVE-2024-3931 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-3931 is a medium-severity cross-site scripting vulnerability in Totara LMS, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-3931 and fix it if it is affected.\n\nWhat it is: CVE-2024-3931 is a medium-severity cross-site scripting vulnerability in Totara LMS, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3931 exists.\n\nAffected product: Totara LMS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3931/ (Markdown: https://insights.sbomify.com/CVE-2024-3931/index.md)","id":"CVE-2024-3931","markdown":"https://insights.sbomify.com/CVE-2024-3931/index.md","name":"CVE-2024-3931","record":{"aliases":["GHSA-94h5-8cv5-pxxm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Totara LMS","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the ID Number argument in Totara LMS, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"totara","vendor":"totara"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Totara LMS up to 18.7. It has been rated as problematic. Affected by this issue is some unknown functionality of the file admin/roles/check.php of the component User Selector. The manipulation of the argument ID Number leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Totara LMS User Selector check.php cross site scripting","id":"CVE-2024-3931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"Totara LMS User Selector cross-site request forgery","id":"CVE-2024-3932"},"packages":[],"prev":{"headline":"XML External Entity in Akana","id":"CVE-2024-3930"},"products":["LMS"],"published":"2024-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["Totara"]},"summary":"Remote attackers can inject malicious scripts via the ID Number argument in Totara LMS, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2024-3931/"}