{"answers":{"affected":"2 open source packages ship an affected version, including publify_core. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39311 exists.","fix":"Upgrade publify_core to 10.0.2 or later.","what":"CVE-2024-39311 is a low-severity cross-site scripting vulnerability in publify, published on 28 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-39311 and fix it if it is affected.\n\nWhat it is: CVE-2024-39311 is a low-severity cross-site scripting vulnerability in publify, published on 28 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39311 exists.\n\nAffected packages and fixed versions:\n- publify_core (RubyGems): affected all versions; fixed in 10.0.2\n- publify_core (RubyGems): affected all versions; fixed in 10.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39311/ (Markdown: https://insights.sbomify.com/CVE-2024-39311/index.md)","id":"CVE-2024-39311","markdown":"https://insights.sbomify.com/CVE-2024-39311/index.md","name":"CVE-2024-39311","record":{"aliases":["GHSA-8fm5-gg2f-f66q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Publify publishing platform","requires_auth":"high_privilege","summary":"A publisher can execute XSS on an administrator via malicious redirects, potentially escalating privileges to admin. Upgrade Publify to fix.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"publify","vendor":"publify"},{"product":"publify_core","vendor":"publify"}],"cvss":{"score":1.8,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Publify is a self hosted Web publishing platform on Rails. Prior to version 10.0.1 of Publify, corresponding to versions prior to 10.0.2 of the `publify_core` rubygem, publisher on a `publify` application is able to perform a cross-site scripting (XSS) attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. A publisher may attempt to use this vulnerability to escalate their privileges and become an administrator. Version 10.0.1 of Publify and version 10.0.2 of the `publify_core` rubygem fix the issue.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction","id":"CVE-2024-39311","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Botan has an Authorization Error due to Name Constraint Decoding Bug","id":"CVE-2024-39312"},"packages":[{"ecosystem":"RubyGems","fixed":["10.0.2"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":null,"source":"GHSA-8fm5-gg2f-f66q"},{"ecosystem":"RubyGems","fixed":["10.0.2"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":"pkg:gem/publify_core","source":"GHSA-8fm5-gg2f-f66q"}],"prev":{"headline":"WordPress Basil Theme Authenticated (Contributor+) Persistent Cross-Site Scripting Vulnerability","id":"CVE-2024-39310"},"products":["publify"],"published":"2025-03-28","related":[{"cvss_score":7.5,"headline":"Publify vulnerable to DoS attack","id":"CVE-2014-3211","kev_date_added":null,"published":"2020-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-28","vendors":["publify"]},"summary":"A publisher can execute XSS on an administrator via malicious redirects, potentially escalating privileges to admin. Upgrade Publify to fix.","url":"https://insights.sbomify.com/CVE-2024-39311/"}