# CVE-2024-39314: toy-blog administrative token leaked through the command line parameter

> Attackers can read the administrative password from command line parameters, leading to unauthorized access and potential account takeover.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-q8g2-c3x5-gp89

## What is CVE-2024-39314?

CVE-2024-39314 is a medium-severity vulnerability in KisaragiEffective toy-blog, published on 1 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

toy-blog is a headless content management system implementation. Starting in version 0.4.3 and prior to version 0.5.0, the administrative password was leaked through the command line parameter. The problem was patched in version 0.5.0. As a workaround, pass `--read-bearer-token-from-stdin` to the launch arguments and feed the token from the standard input in version 0.4.14 or later. Earlier versions do not have this workaround.

Weakness: CWE-214 (Invocation of Process Using Visible Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-39314?


## How do I fix CVE-2024-39314?

No fix has been published for CVE-2024-39314 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-39314 being exploited?

There is no known exploitation of CVE-2024-39314 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39314 and fix it if it is affected.

What it is: CVE-2024-39314 is a medium-severity vulnerability in KisaragiEffective toy-blog, published on 1 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39314 in the wild and no public exploit code.

Affected product: KisaragiEffective toy-blog. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39314/ (Markdown: https://insights.sbomify.com/CVE-2024-39314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39314
- OSV: https://osv.dev/vulnerability/CVE-2024-39314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39314/
Summaries are generated and may contain mistakes; the official description above is the record.
