# CVE-2024-39315: Pomerium exposed OAuth2 access and ID tokens in user info endpoint response

> Pomerium exposed OAuth2 tokens in user info endpoint, allowing attackers to potentially impersonate users if combined with XSS in proxied apps.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-rrqr-7w59-637v, GO-2024-2965

## What is CVE-2024-39315?

CVE-2024-39315 is a medium-severity vulnerability in pomerium, published on 2 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Pomerium is an identity and context-aware access proxy. Prior to version 0.26.1, the Pomerium user info page (at `/.pomerium`) unintentionally included serialized OAuth2 access and ID tokens from the logged-in user's session. These tokens are not intended to be exposed to end users. This issue may be more severe in the presence of a cross-site scripting vulnerability in an upstream application proxied through Pomerium. If an attacker could insert a malicious script onto a web page proxied through Pomerium, that script could access these tokens by making a request to the `/.pomerium` endpoint. Upstream applications that authenticate only the ID token may be vulnerable to user impersonation using a token obtained in this manner. Note that an OAuth2 access token or ID token by itself is not sufficient to hijack a user's Pomerium session. Upstream applications should not be vulnerable to user impersonation via these tokens provided the application verifies the Pomerium JWT for each request, the connection between Pomerium and the application is secured by mTLS, or the connection between Pomerium and the application is otherwise secured at the network layer. The issue is patched in Pomerium v0.26.1. No known workarounds are available.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2024-39315?

3 open source packages ship an affected version, including github.com/pomerium/pomerium. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pomerium/pomerium` | Go | All versions | 0.26.1 |
| `github.com/pomerium/pomerium` | Go | All versions | 0.26.1 |
| `github.com/pomerium/pomerium` | Go | All versions | 0.26.1 |

Products: Pomerium Pomerium.

## How do I fix CVE-2024-39315?

Upgrade github.com/pomerium/pomerium to 0.26.1 or later.

## Is CVE-2024-39315 being exploited?

There is no known exploitation of CVE-2024-39315 in the wild and no public exploit code.

## Other vulnerabilities in pomerium

- [CVE-2023-33189](https://insights.sbomify.com/CVE-2023-33189/): Incorrect Authorization with specially crafted requests (critical 10.0)
- [CVE-2022-24797](https://insights.sbomify.com/CVE-2022-24797/): Exposure of Sensitive Information in Pomerium (medium 6.5)
- [CVE-2021-29651](https://insights.sbomify.com/CVE-2021-29651/): JWT leak via Open Redirect in Programmatic access (medium 6.1)
- [CVE-2021-29652](https://insights.sbomify.com/CVE-2021-29652/): pomerium_signature is not verified in middleware in github.com/pomerium/pomerium (medium 6.1)
- [CVE-2021-41230](https://insights.sbomify.com/CVE-2021-41230/): OIDC claims not updated from Identity Provider in Pomerium (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39315 and fix it if it is affected.

What it is: CVE-2024-39315 is a medium-severity vulnerability in pomerium, published on 2 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39315 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.26.1
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.26.1
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.26.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39315/ (Markdown: https://insights.sbomify.com/CVE-2024-39315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39315
- OSV: https://osv.dev/vulnerability/CVE-2024-39315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39315/
Summaries are generated and may contain mistakes; the official description above is the record.
