{"answers":{"affected":"2 open source packages ship an affected version, including ibexa/admin-ui.","exploited":"There is no known exploitation of CVE-2024-39318 in the wild and no public exploit code.","fix":"Upgrade ibexa/admin-ui to 4.6.9 or later.","what":"CVE-2024-39318 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 31 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-39318 and fix it if it is affected.\n\nWhat it is: CVE-2024-39318 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 31 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-39318 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ibexa/admin-ui (Packagist): affected from 4.6.0-beta1; fixed in 4.6.9\n- ibexa/admin-ui (Packagist): affected from 4.6.0-beta1; fixed in 4.6.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39318/ (Markdown: https://insights.sbomify.com/CVE-2024-39318/index.md)","id":"CVE-2024-39318","markdown":"https://insights.sbomify.com/CVE-2024-39318/index.md","name":"CVE-2024-39318","record":{"aliases":["GHSA-qm44-wjm2-pr59"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ibexa Admin UI","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts in the browser of an authenticated editor or administrator by tricking them into uploading a file with a malicious filename.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Ibexa Admin UI Bundle contains all the necessary parts to run the Ibexa DXP Back Office interface. The file upload widget is vulnerable to XSS payloads in filenames. Access permission to upload files is required. As such, in most cases only authenticated editors and administrators will have the required permission. It is not persistent, i.e. the payload is only executed during the upload. In effect, an attacker will have to trick an editor/administrator into uploading a strangely named file.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ibexa Admin UI vulnerable to DOM-based Cross-site Scripting in file upload widget","id":"CVE-2024-39318","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"aimeos/ai-controller-frontend has IDOR vulnerability in account profile page","id":"CVE-2024-39319"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.9"],"introduced":["4.6.0-beta1"],"last_affected":[],"package":"ibexa/admin-ui","purl":null,"source":"GHSA-qm44-wjm2-pr59"},{"ecosystem":"Packagist","fixed":["4.6.9"],"introduced":["4.6.0-beta1"],"last_affected":[],"package":"ibexa/admin-ui","purl":"pkg:composer/ibexa/admin-ui","source":"GHSA-qm44-wjm2-pr59"}],"prev":{"headline":"Wagtail regular expression denial-of-service via search query parsing","id":"CVE-2024-39317"},"products":["admin-ui"],"published":"2024-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["ibexa"]},"summary":"An attacker can execute arbitrary scripts in the browser of an authenticated editor or administrator by tricking them into uploading a file with a malicious filename.","url":"https://insights.sbomify.com/CVE-2024-39318/"}