# CVE-2024-39318: Ibexa Admin UI vulnerable to DOM-based Cross-site Scripting in file upload widget

> An attacker can execute arbitrary scripts in the browser of an authenticated editor or administrator by tricking them into uploading a file with a malicious filename.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-qm44-wjm2-pr59

## What is CVE-2024-39318?

CVE-2024-39318 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 31 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Ibexa Admin UI Bundle contains all the necessary parts to run the Ibexa DXP Back Office interface. The file upload widget is vulnerable to XSS payloads in filenames. Access permission to upload files is required. As such, in most cases only authenticated editors and administrators will have the required permission. It is not persistent, i.e. the payload is only executed during the upload. In effect, an attacker will have to trick an editor/administrator into uploading a strangely named file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-39318?

2 open source packages ship an affected version, including ibexa/admin-ui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ibexa/admin-ui` | Packagist | From 4.6.0-beta1 | 4.6.9 |
| `ibexa/admin-ui` | Packagist | From 4.6.0-beta1 | 4.6.9 |

## How do I fix CVE-2024-39318?

Upgrade ibexa/admin-ui to 4.6.9 or later.

## Is CVE-2024-39318 being exploited?

There is no known exploitation of CVE-2024-39318 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39318 and fix it if it is affected.

What it is: CVE-2024-39318 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 31 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39318 in the wild and no public exploit code.

Affected packages and fixed versions:
- ibexa/admin-ui (Packagist): affected from 4.6.0-beta1; fixed in 4.6.9
- ibexa/admin-ui (Packagist): affected from 4.6.0-beta1; fixed in 4.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39318/ (Markdown: https://insights.sbomify.com/CVE-2024-39318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39318
- OSV: https://osv.dev/vulnerability/CVE-2024-39318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39318/
Summaries are generated and may contain mistakes; the official description above is the record.
