# CVE-2024-39319: aimeos/ai-controller-frontend has IDOR vulnerability in account profile page

> An insecure direct object reference allows attackers to disable subscriptions and reviews of other customers in Aimeos e-commerce projects.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2024
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-rw3j-574h-mrcq

## What is CVE-2024-39319?

CVE-2024-39319 is a medium-severity missing authorization vulnerability in aimeos ai-controller-frontend, published on 26 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aimeos/ai-controller-frontend is the Aimeos frontend controller package for e-commerce projects. Prior to versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15, an insecure direct object reference allows an attacker to disable subscriptions and reviews of another customer. Versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15 fix this issue.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-39319?

10 open source packages ship an affected version, including aimeos/ai-controller-frontend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/ai-controller-frontend` | Packagist | All versions | 2020.10.15 |
| `aimeos/ai-controller-frontend` | Packagist | All versions | 2020.10.15 |
| `aimeos/ai-controller-frontend` | Packagist | From 2021.04.1 | 2021.10.8 |
| `aimeos/ai-controller-frontend` | Packagist | From 2021.04.1 | 2021.10.8 |
| `aimeos/ai-controller-frontend` | Packagist | From 2022.04.1 | 2022.10.8 |
| `aimeos/ai-controller-frontend` | Packagist | From 2022.04.1 | 2022.10.8 |
| `aimeos/ai-controller-frontend` | Packagist | From 2023.04.1 | 2023.10.9 |
| `aimeos/ai-controller-frontend` | Packagist | From 2023.04.1 | 2023.10.9 |
| `aimeos/ai-controller-frontend` | Packagist | From 2024.04.1 | 2024.04.2 |
| `aimeos/ai-controller-frontend` | Packagist | From 2024.04.1 | 2024.04.2 |

Products: Aimeos Aimeos Frontend Controller.

## How do I fix CVE-2024-39319?

Upgrade aimeos/ai-controller-frontend to a fixed version for your release line: 2020.10.15, 2021.10.8, 2022.10.8 or 2023.10.9.

## Is CVE-2024-39319 being exploited?

There is no known exploitation of CVE-2024-39319 in the wild and no public exploit code.

## Other vulnerabilities in aimeos ai-controller-frontend

- [CVE-2024-39325](https://insights.sbomify.com/CVE-2024-39325/): aimeos/ai-controller-frontend doesn't reset payment status in basket (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39319 and fix it if it is affected.

What it is: CVE-2024-39319 is a medium-severity missing authorization vulnerability in aimeos ai-controller-frontend, published on 26 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39319 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/ai-controller-frontend (Packagist): affected all versions; fixed in 2020.10.15
- aimeos/ai-controller-frontend (Packagist): affected all versions; fixed in 2020.10.15
- aimeos/ai-controller-frontend (Packagist): affected from 2021.04.1; fixed in 2021.10.8
- aimeos/ai-controller-frontend (Packagist): affected from 2021.04.1; fixed in 2021.10.8
- aimeos/ai-controller-frontend (Packagist): affected from 2022.04.1; fixed in 2022.10.8
- aimeos/ai-controller-frontend (Packagist): affected from 2022.04.1; fixed in 2022.10.8
- aimeos/ai-controller-frontend (Packagist): affected from 2023.04.1; fixed in 2023.10.9
- aimeos/ai-controller-frontend (Packagist): affected from 2023.04.1; fixed in 2023.10.9
- aimeos/ai-controller-frontend (Packagist): affected from 2024.04.1; fixed in 2024.04.2
- aimeos/ai-controller-frontend (Packagist): affected from 2024.04.1; fixed in 2024.04.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39319/ (Markdown: https://insights.sbomify.com/CVE-2024-39319/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39319
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39319
- OSV: https://osv.dev/vulnerability/CVE-2024-39319

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39319/
Summaries are generated and may contain mistakes; the official description above is the record.
