CVE-2024-3932 Totara LMS User Selector cross-site request forgery

Low 2.3 Published Updated

Attackers can perform cross-site request forgery attacks against the User Selector component in Totara LMS, requiring user interaction.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-3932?

CVE-2024-3932 is a low-severity vulnerability in Totara LMS, published on 18 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic has been found in Totara LMS up to 18.7. This affects an unknown part of the component User Selector. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-862, CWE-352

Which versions are affected by CVE-2024-3932?

How do I fix CVE-2024-3932?

No fix has been published for CVE-2024-3932 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-3932 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3932 exists.

Sources

Also known as GHSA-jj7c-wrfh-7qqh.

Is CVE-2024-3932 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free