{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3932 exists.","fix":"No fix has been published for CVE-2024-3932 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-3932 is a low-severity vulnerability in Totara LMS, published on 18 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-3932 and fix it if it is affected.\n\nWhat it is: CVE-2024-3932 is a low-severity vulnerability in Totara LMS, published on 18 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3932 exists.\n\nAffected product: Totara LMS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3932/ (Markdown: https://insights.sbomify.com/CVE-2024-3932/index.md)","id":"CVE-2024-3932","markdown":"https://insights.sbomify.com/CVE-2024-3932/index.md","name":"CVE-2024-3932","record":{"aliases":["GHSA-jj7c-wrfh-7qqh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Totara LMS","requires_auth":"none","summary":"Attackers can perform cross-site request forgery attacks against the User Selector component in Totara LMS, requiring user interaction.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A vulnerability classified as problematic has been found in Totara LMS up to 18.7. This affects an unknown part of the component User Selector. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Totara LMS User Selector cross-site request forgery","id":"CVE-2024-3932","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Eclipse Open J9 With -Xgc:concurrentScavenge on IBM Z, could write/read outside of a buffer","id":"CVE-2024-3933"},"packages":[],"prev":{"headline":"Totara LMS User Selector check.php cross site scripting","id":"CVE-2024-3931"},"products":["LMS"],"published":"2024-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-11","vendors":["Totara"]},"summary":"Attackers can perform cross-site request forgery attacks against the User Selector component in Totara LMS, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2024-3932/"}