CVE-2024-39320 Discourse allows iframe injection though default site setting

Medium 6.1 Published Updated

Attackers can inject arbitrary iframes bypassing restrictions, potentially leading to code execution or security bypass in Discourse forums.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-39320?

CVE-2024-39320 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.

Weakness: CWE-74, CWE-1021

Which versions are affected by CVE-2024-39320?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.2.5

Products include Discourse Discourse.

How do I fix CVE-2024-39320?

Upgrade discourse to 3.2.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-39320 being exploited?

There is no known exploitation of CVE-2024-39320 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2024-39320, GHSA-4p82-xh38-gq4p.

Is CVE-2024-39320 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free