# CVE-2024-39320: Discourse allows iframe injection though default site setting

> Attackers can inject arbitrary iframes bypassing restrictions, potentially leading to code execution or security bypass in Discourse forums.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-discourse-2024-39320, GHSA-4p82-xh38-gq4p

## What is CVE-2024-39320?

CVE-2024-39320 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2024-39320?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.2.5 |

Products: Discourse Discourse.

## How do I fix CVE-2024-39320?

Upgrade discourse to 3.2.5 or later.

## Is CVE-2024-39320 being exploited?

There is no known exploitation of CVE-2024-39320 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39320 and fix it if it is affected.

What it is: CVE-2024-39320 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39320 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39320/ (Markdown: https://insights.sbomify.com/CVE-2024-39320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39320
- OSV: https://osv.dev/vulnerability/CVE-2024-39320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39320/
Summaries are generated and may contain mistakes; the official description above is the record.
