CVE-2024-39322 aimeos/ai-admin-jsonadm improper access control vulnerability allows editors to remove required records
Editors can improperly delete critical admin group and locale configurations in the Aimeos backend due to missing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-39322?
CVE-2024-39322 is a medium-severity missing authorization vulnerability in aimeos ai-admin-jsonadm, published on 2 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
aimeos/ai-admin-jsonadm is the Aimeos e-commerce JSON API for administrative tasks. In versions prior to 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2, improper access control allows editors to remove admin group and locale configuration in the Aimeos backend. Versions 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2 contain a fix for the issue.
Weakness: CWE-863
Which versions are affected by CVE-2024-39322?
10 open source packages ship an affected version, including aimeos/ai-admin-jsonadm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
aimeos/ai-admin-jsonadm Packagist | All versions | 2020.10.13 |
aimeos/ai-admin-jsonadm Packagist | All versions | 2020.10.13 |
aimeos/ai-admin-jsonadm Packagist | From 2021.04.1 | 2021.10.6 |
aimeos/ai-admin-jsonadm Packagist | From 2021.04.1 | 2021.10.6 |
aimeos/ai-admin-jsonadm Packagist | From 2022.04.1 | 2022.10.3 |
aimeos/ai-admin-jsonadm Packagist | From 2022.04.1 | 2022.10.3 |
4 more packages
aimeos/ai-admin-jsonadm Packagist | From 2023.04.1 | 2023.10.4 |
aimeos/ai-admin-jsonadm Packagist | From 2023.04.1 | 2023.10.4 |
aimeos/ai-admin-jsonadm Packagist | From 2024.04.1 | 2024.04.2 |
aimeos/ai-admin-jsonadm Packagist | From 2024.04.1 | 2024.04.2 |
Products include Aimeos Project Ai-Controller-Frontend.
How do I fix CVE-2024-39322?
Upgrade aimeos/ai-admin-jsonadm to a fixed version for your release line: 2020.10.13, 2021.10.6, 2022.10.3 or 2023.10.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-39322 being exploited?
There is no known exploitation of CVE-2024-39322 in the wild and no public exploit code.
Sources
Also known as GHSA-8fj2-587w-5whr.