{"answers":{"affected":"10 open source packages ship an affected version, including aimeos/ai-admin-jsonadm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-39322 in the wild and no public exploit code.","fix":"Upgrade aimeos/ai-admin-jsonadm to a fixed version for your release line: 2020.10.13, 2021.10.6, 2022.10.3 or 2023.10.4.","what":"CVE-2024-39322 is a medium-severity missing authorization vulnerability in aimeos ai-admin-jsonadm, published on 2 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39322 and fix it if it is affected.\n\nWhat it is: CVE-2024-39322 is a medium-severity missing authorization vulnerability in aimeos ai-admin-jsonadm, published on 2 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-39322 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aimeos/ai-admin-jsonadm (Packagist): affected all versions; fixed in 2020.10.13\n- aimeos/ai-admin-jsonadm (Packagist): affected all versions; fixed in 2020.10.13\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2021.04.1; fixed in 2021.10.6\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2021.04.1; fixed in 2021.10.6\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2022.04.1; fixed in 2022.10.3\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2022.04.1; fixed in 2022.10.3\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2023.04.1; fixed in 2023.10.4\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2023.04.1; fixed in 2023.10.4\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2024.04.1; fixed in 2024.04.2\n- aimeos/ai-admin-jsonadm (Packagist): affected from 2024.04.1; fixed in 2024.04.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39322/ (Markdown: https://insights.sbomify.com/CVE-2024-39322/index.md)","id":"CVE-2024-39322","markdown":"https://insights.sbomify.com/CVE-2024-39322/index.md","name":"CVE-2024-39322","record":{"aliases":["GHSA-8fj2-587w-5whr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Aimeos e-commerce admin","requires_auth":"high_privilege","summary":"Editors can improperly delete critical admin group and locale configurations in the Aimeos backend due to missing authorization checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ai-controller-frontend","vendor":"aimeos_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"aimeos/ai-admin-jsonadm is the Aimeos e-commerce JSON API for administrative tasks. In versions prior to 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2, improper access control allows editors to remove admin group and locale configuration in the Aimeos backend. Versions 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2 contain a fix for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"aimeos/ai-admin-jsonadm improper access control vulnerability allows editors to remove required records","id":"CVE-2024-39322","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":10,"n_references":6,"next":{"headline":"aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account","id":"CVE-2024-39323"},"packages":[{"ecosystem":"Packagist","fixed":["2020.10.13"],"introduced":["0"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":null,"source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2020.10.13"],"introduced":["0"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":"pkg:composer/aimeos/ai-admin-jsonadm","source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2021.10.6"],"introduced":["2021.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":null,"source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2021.10.6"],"introduced":["2021.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":"pkg:composer/aimeos/ai-admin-jsonadm","source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2022.10.3"],"introduced":["2022.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":null,"source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2022.10.3"],"introduced":["2022.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":"pkg:composer/aimeos/ai-admin-jsonadm","source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2023.10.4"],"introduced":["2023.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":null,"source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2023.10.4"],"introduced":["2023.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":"pkg:composer/aimeos/ai-admin-jsonadm","source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2024.04.2"],"introduced":["2024.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":null,"source":"GHSA-8fj2-587w-5whr"},{"ecosystem":"Packagist","fixed":["2024.04.2"],"introduced":["2024.04.1"],"last_affected":[],"package":"aimeos/ai-admin-jsonadm","purl":"pkg:composer/aimeos/ai-admin-jsonadm","source":"GHSA-8fj2-587w-5whr"}],"prev":{"headline":"Traefik vulnerable to bypassing IP allow-lists via HTTP/3 early data requests in QUIC 0-RTT handshakes","id":"CVE-2024-39321"},"products":["ai-admin-jsonadm"],"published":"2024-07-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["aimeos"]},"summary":"Editors can improperly delete critical admin group and locale configurations in the Aimeos backend due to missing authorization checks.","url":"https://insights.sbomify.com/CVE-2024-39322/"}