# CVE-2024-39322: aimeos/ai-admin-jsonadm improper access control vulnerability allows editors to remove required records

> Editors can improperly delete critical admin group and locale configurations in the Aimeos backend due to missing authorization checks.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8fj2-587w-5whr

## What is CVE-2024-39322?

CVE-2024-39322 is a medium-severity missing authorization vulnerability in aimeos ai-admin-jsonadm, published on 2 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

aimeos/ai-admin-jsonadm is the Aimeos e-commerce JSON API for administrative tasks. In versions prior to 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2, improper access control allows editors to remove admin group and locale configuration in the Aimeos backend. Versions 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2 contain a fix for the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-39322?

10 open source packages ship an affected version, including aimeos/ai-admin-jsonadm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/ai-admin-jsonadm` | Packagist | All versions | 2020.10.13 |
| `aimeos/ai-admin-jsonadm` | Packagist | All versions | 2020.10.13 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2021.04.1 | 2021.10.6 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2021.04.1 | 2021.10.6 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2022.04.1 | 2022.10.3 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2022.04.1 | 2022.10.3 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2023.04.1 | 2023.10.4 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2023.04.1 | 2023.10.4 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2024.04.1 | 2024.04.2 |
| `aimeos/ai-admin-jsonadm` | Packagist | From 2024.04.1 | 2024.04.2 |

Products: Aimeos Project Ai-Controller-Frontend.

## How do I fix CVE-2024-39322?

Upgrade aimeos/ai-admin-jsonadm to a fixed version for your release line: 2020.10.13, 2021.10.6, 2022.10.3 or 2023.10.4.

## Is CVE-2024-39322 being exploited?

There is no known exploitation of CVE-2024-39322 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39322 and fix it if it is affected.

What it is: CVE-2024-39322 is a medium-severity missing authorization vulnerability in aimeos ai-admin-jsonadm, published on 2 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39322 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/ai-admin-jsonadm (Packagist): affected all versions; fixed in 2020.10.13
- aimeos/ai-admin-jsonadm (Packagist): affected all versions; fixed in 2020.10.13
- aimeos/ai-admin-jsonadm (Packagist): affected from 2021.04.1; fixed in 2021.10.6
- aimeos/ai-admin-jsonadm (Packagist): affected from 2021.04.1; fixed in 2021.10.6
- aimeos/ai-admin-jsonadm (Packagist): affected from 2022.04.1; fixed in 2022.10.3
- aimeos/ai-admin-jsonadm (Packagist): affected from 2022.04.1; fixed in 2022.10.3
- aimeos/ai-admin-jsonadm (Packagist): affected from 2023.04.1; fixed in 2023.10.4
- aimeos/ai-admin-jsonadm (Packagist): affected from 2023.04.1; fixed in 2023.10.4
- aimeos/ai-admin-jsonadm (Packagist): affected from 2024.04.1; fixed in 2024.04.2
- aimeos/ai-admin-jsonadm (Packagist): affected from 2024.04.1; fixed in 2024.04.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39322/ (Markdown: https://insights.sbomify.com/CVE-2024-39322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39322
- OSV: https://osv.dev/vulnerability/CVE-2024-39322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39322/
Summaries are generated and may contain mistakes; the official description above is the record.
