CVE-2024-39323 aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account
An editor can improperly modify and take over an admin account in the Aimeos GraphQL API admin interface due to missing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-39323?
CVE-2024-39323 is a high-severity missing authorization vulnerability in aimeos ai-admin-graphql, published on 2 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.01 and prior to versions 2022.10.10, 2023.10.6, and 2024.04.6, an improper access control vulnerability allows an editor to modify and take over an admin account in the back end. Versions 2022.10.10, 2023.10.6, and 2024.04.6 fix this issue.
Which versions are affected by CVE-2024-39323?
6 open source packages ship an affected version, including aimeos/ai-admin-graphql.
| Package | Affected | Fixed in |
|---|---|---|
aimeos/ai-admin-graphql Packagist | From 2022.04.1 | 2022.10.10 |
aimeos/ai-admin-graphql Packagist | From 2022.04.1 | 2022.10.10 |
aimeos/ai-admin-graphql Packagist | From 2023.04.1 | 2023.10.6 |
aimeos/ai-admin-graphql Packagist | From 2023.04.1 | 2023.10.6 |
aimeos/ai-admin-graphql Packagist | From 2024.04.1 | 2024.04.6 |
aimeos/ai-admin-graphql Packagist | From 2024.04.1 | 2024.04.6 |
How do I fix CVE-2024-39323?
Upgrade aimeos/ai-admin-graphql to a fixed version for your release line: 2022.10.10, 2023.10.6 or 2024.04.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-39323 being exploited?
There is no known exploitation of CVE-2024-39323 in the wild and no public exploit code.
Sources
Also known as GHSA-vc7j-99jw-jrqm.