# CVE-2024-39323: aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account

> An editor can improperly modify and take over an admin account in the Aimeos GraphQL API admin interface due to missing authorization checks.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vc7j-99jw-jrqm

## What is CVE-2024-39323?

CVE-2024-39323 is a high-severity missing authorization vulnerability in aimeos ai-admin-graphql, published on 2 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.01 and prior to versions 2022.10.10, 2023.10.6, and 2024.04.6, an improper access control vulnerability allows an editor to modify and take over an admin account in the back end. Versions 2022.10.10, 2023.10.6, and 2024.04.6 fix this issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2024-39323?

6 open source packages ship an affected version, including aimeos/ai-admin-graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/ai-admin-graphql` | Packagist | From 2022.04.1 | 2022.10.10 |
| `aimeos/ai-admin-graphql` | Packagist | From 2022.04.1 | 2022.10.10 |
| `aimeos/ai-admin-graphql` | Packagist | From 2023.04.1 | 2023.10.6 |
| `aimeos/ai-admin-graphql` | Packagist | From 2023.04.1 | 2023.10.6 |
| `aimeos/ai-admin-graphql` | Packagist | From 2024.04.1 | 2024.04.6 |
| `aimeos/ai-admin-graphql` | Packagist | From 2024.04.1 | 2024.04.6 |

## How do I fix CVE-2024-39323?

Upgrade aimeos/ai-admin-graphql to a fixed version for your release line: 2022.10.10, 2023.10.6 or 2024.04.6.

## Is CVE-2024-39323 being exploited?

There is no known exploitation of CVE-2024-39323 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39323 and fix it if it is affected.

What it is: CVE-2024-39323 is a high-severity missing authorization vulnerability in aimeos ai-admin-graphql, published on 2 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39323 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/ai-admin-graphql (Packagist): affected from 2022.04.1; fixed in 2022.10.10
- aimeos/ai-admin-graphql (Packagist): affected from 2022.04.1; fixed in 2022.10.10
- aimeos/ai-admin-graphql (Packagist): affected from 2023.04.1; fixed in 2023.10.6
- aimeos/ai-admin-graphql (Packagist): affected from 2023.04.1; fixed in 2023.10.6
- aimeos/ai-admin-graphql (Packagist): affected from 2024.04.1; fixed in 2024.04.6
- aimeos/ai-admin-graphql (Packagist): affected from 2024.04.1; fixed in 2024.04.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39323/ (Markdown: https://insights.sbomify.com/CVE-2024-39323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39323
- OSV: https://osv.dev/vulnerability/CVE-2024-39323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39323/
Summaries are generated and may contain mistakes; the official description above is the record.
