# CVE-2024-39330: Django Path Traversal vulnerability

> Custom Django storage classes missing path validation allow directory traversal, enabling attackers to read or modify files outside the intended directory.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2024
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-django-2024-39330, CLSA-2025-1757635895, DEBIAN-CVE-2024-39330, GHSA-9jmf-237g-qf46, PYSEC-2024-58, UBUNTU-CVE-2024-39330, openSUSE-SU-2026:10125-1

## What is CVE-2024-39330?

CVE-2024-39330 is a medium-severity path traversal vulnerability in Djangoproject Django, published on 10 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. Derived classes of the django.core.files.storage.Storage base class, when they override generate_filename() without replicating the file-path validations from the parent class, potentially allow directory traversal via certain inputs during a save() call. (Built-in Storage sub-classes are unaffected.)

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-39330?

6 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.14, 5.0.7 |
| `django` | PyPI | From 4.2 | 4.2.14 |
| `django` | PyPI | From 5.0 | 5.0.7, 4.2.14 |
| `django` | PyPI | From 5.0 | 5.0.7 |
| `Django` | PyPI | From 4.2 | 4.2.14 |
| `Django` | PyPI | From 5.0 | 5.0.7 |
| `python-django-storages` | openSUSE:Tumbleweed | All versions | 1.14.6-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2024-39330?

Upgrade django to a fixed version for your release line: 4.2.14 or 5.0.7.

## Is CVE-2024-39330 being exploited?

There is no known exploitation of CVE-2024-39330 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39330 and fix it if it is affected.

What it is: CVE-2024-39330 is a medium-severity path traversal vulnerability in Djangoproject Django, published on 10 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39330 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.14, 5.0.7
- django (PyPI): affected from 4.2; fixed in 4.2.14
- django (PyPI): affected from 5.0; fixed in 5.0.7, 4.2.14
- django (PyPI): affected from 5.0; fixed in 5.0.7
- Django (PyPI): affected from 4.2; fixed in 4.2.14
- Django (PyPI): affected from 5.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39330/ (Markdown: https://insights.sbomify.com/CVE-2024-39330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39330
- OSV: https://osv.dev/vulnerability/CVE-2024-39330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39330/
Summaries are generated and may contain mistakes; the official description above is the record.
