# CVE-2024-39340: Auth bypass in n/a

> Attackers can bypass second-factor authentication in the administration interface and user portal when OTP is enabled.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Jul 2024
- **Updated:** 23 Sep 2024
- **Also known as:** GHSA-vc4m-x7gg-xqpc

## What is CVE-2024-39340?

CVE-2024-39340 is a high-severity authentication bypass vulnerability in n/a, published on 12 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The authentication system of Securepoint UTM mishandles OTP keys. This allows the bypassing of second-factor verification (when OTP is enabled) in both the administration web interface and the user portal. Affected versions include UTM 11.5 through 12.6.4 and Reseller Preview 12.7.0. The issue has been fixed in UTM 12.6.5 and 12.7.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-39340?


## How do I fix CVE-2024-39340?

No fix has been published for CVE-2024-39340 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-39340 being exploited?

There is no known exploitation of CVE-2024-39340 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39340 and fix it if it is affected.

What it is: CVE-2024-39340 is a high-severity authentication bypass vulnerability in n/a, published on 12 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39340 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39340/ (Markdown: https://insights.sbomify.com/CVE-2024-39340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39340
- OSV: https://osv.dev/vulnerability/CVE-2024-39340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39340/
Summaries are generated and may contain mistakes; the official description above is the record.
