CVE-2024-39573 Apache HTTP Server: mod_rewrite proxy handler substitution
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-39573?
CVE-2024-39573 is a high-severity vulnerability in Apache Http Server, published on 1 Jul 2024.
Official description
Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Weakness: CWE-20
Which versions are affected by CVE-2024-39573?
1 open source package ship an affected version, including apache. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.60 |
Products include Apache Http Server, Netapp Ontap.
How do I fix CVE-2024-39573?
Upgrade apache to 2.4.60 or later.
Is CVE-2024-39573 being exploited?
There is no known exploitation of CVE-2024-39573 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2024-39573, BELL-CVE-2024-39573, BIT-apache-2024-39573, CLEANSTART-2026-WF86343, DEBIAN-CVE-2024-39573, GHSA-2wcw-rcf9-qm36 and 1 more.