# CVE-2024-39573: Apache HTTP Server: mod_rewrite proxy handler substitution


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2024-39573, BELL-CVE-2024-39573, BIT-apache-2024-39573, CLEANSTART-2026-WF86343, DEBIAN-CVE-2024-39573, GHSA-2wcw-rcf9-qm36, UBUNTU-CVE-2024-39573

## What is CVE-2024-39573?

CVE-2024-39573 is a high-severity vulnerability in Apache Http Server, published on 1 Jul 2024. 

### Official description

Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-39573?

1 open source package ship an affected version, including apache. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.60 |

Products: Apache Http Server, Netapp Ontap.

## How do I fix CVE-2024-39573?

Upgrade apache to 2.4.60 or later.

## Is CVE-2024-39573 being exploited?

There is no known exploitation of CVE-2024-39573 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39573 and fix it if it is affected.

What it is: CVE-2024-39573 is a high-severity vulnerability in Apache Http Server, published on 1 Jul 2024. 
Exploitation: There is no known exploitation of CVE-2024-39573 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39573/ (Markdown: https://insights.sbomify.com/CVE-2024-39573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39573
- OSV: https://osv.dev/vulnerability/CVE-2024-39573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39573/
Summaries are generated and may contain mistakes; the official description above is the record.
